fu7mu4’s diary

はてなダイアリーから移転しました。

Package `emacs-24.1' is unavailable といわれた

こんなエラーがでたのでぐぐって解決した。

emacs24以上にはデフォルトでpackage.elがインストールされています
emacsバージョンアップした等でタイトルのエラーが出る場合には
独自でインストールした package.el を移動(もしくは削除)してあげる必要があります

http://kakakikikeke.blogspot.jp/2014/08/package-emacs-241-is-unavailable.html

そういえば、ずっと前にいれていたような...

単純に load-path を追加する前に

(require 'package)

を移動させてデフォルトのを読ませたらこのエラーは消えた。