fu7mu4’s diary

はてなダイアリーから移転しました。

cpan upgrade on cygwin of gnupack

gnupack の perl のモジュールが古いんじゃないかとか、新しいモジュールが欲しくなった人もいるだろう。それで、upgradeなんですけどね。

cpan install MP3::Tag

そうしたら、 Unable to find perl 5 とかそういう意味不明なエラーが出たんですよ。だって、cpanperl に含まれているのに。いろいろ調べた結果ですね、

chmod a+x /usr/bin/perl.exe

でいいそうです。あと、cpanでインストールしていたら、書き込めませんとかいわれるんですよ、これも

chmod -R +wx /path/to/perl/lib

みたいなことすれば良いみたい。

どうしてこうなっているんだろうか?