fu7mu4’s diary

はてなダイアリーから移転しました。

Emacs23 + ELPA -> Emacs24.1ではまる

Emacs23系+ELPA を使っていて、Emacs24.1に以降すると、ELPAではまるよ!
というか俺は、やられた。

Emacs24.1では、ELPAが1.0になるんだよね。やったね。
Emacs23系で ELPA使ってたんだけど、それがv0.9だったのね。で起動時にv0.9のELPAがうまくいかなくて....泣きをみることに。

古いELPAのpackage-install.elだか、install-package.elとか、package.elを全部削除する。それからgnuの他のリポジトリを加えていたら、それも一旦削除だ。

それでEmacsを再起動してようやく普通に起動した。